Appointments Tab – Degraded Performance

Incident Report for EMERGE

Resolved

The issue has been resolved.
Posted Jul 13, 2026 - 19:48 UTC

Identified

We’ve identified an issue causing slow performance on the Appointments tab. Our team is actively working on a resolution.

All other areas of EMERGE remain operational. We’ll provide another update as more information becomes available.
Posted Jul 13, 2026 - 18:17 UTC
This incident affected: Web App - Canada.